(Photo by Christian Petersen/Getty Images)

When the PlayStation 5 is released later this year, you will not able to play games from older models.

Reports say the PS5 will not be backwards compatible with PS1, PS2, or PS3 games. It’s not the biggest shock. There were earlier reports of the PS5 being able to play PS4 games.

Many PS4 games are going through testing to make sure they are compatible with the new console.

 

How many old systems do you have tucked away? Do you use them on occasion?

Sign me up for the 105.1 the Bounce email newsletter!

Stay locked in with everything 105.1 the BOUNCE and become a BOUNCE VIP! VIP members can win prizes, concert tickets & get updates on everything Detroit!

*
*
By clicking "Subscribe" I agree to the website's terms of Service and Privacy Policy. I understand I can unsubscribe at any time.